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Version History
Version Description

1.7  Bug Fix: Autodisplay the suffix text picklist fixed
1.6  Bug Fix: cycling through case options did not update 

the Creating text display string
 Slightly reduced the height of the primary screen
 Increased length of the Suffix Text entry field from 

30 to 50 characters
 Reduced the size of the application main window
 Added capability to auto-display the Suffix Text 

droplist
 Added a second suffix entry field after the droplist 

for additional suffix text
1.5  Fixed bug that prevented a period or brace symbols 

from use in the new directory name
 Changed call from Icetips Utilities to WinEvent to 

create the folder to fix period error
1.4  Changed compile mode from DLL to LIB to remove 

.DLL runtime file dependency
  Changed the application icon

1.3 Increased width of the suffix lookup table from 30 to 50 
characters

1.2 Enabled the use of a period (.) symbol within the new 
folder name

1.1  Checked directory creation status return value; 
added error message box if creation failed

 Lengthened suffix field/entry field from 30 
characters to 50 characters

 Changed text color on Why DirTrak tab from white 
to red

1.0 Initial release
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Introduction
DirTrak is a Total Commander add-in utility program which adds a popup window to 
create a new directory within the currently selected folder within Total Commander and 
other Windows file management software that permits the currently active directory 
name to be passed as a variable to an external Windows application. The popup window 
separates a suffix name (useful for naming convention compliance/continuity) to be 
separated from the directory name and the new folder name’s case can be defined as 
lowercase, proper case, uppercase or left “as-is”. Characters not permitted by Windows 
to be used in directory/file names are automatically stripped from the final name to 
prevent errors.

DirTrak has two ‘modes’ of operation.  When DirTrak is NOT passed a folder name as 
parameter then the main DirTrak window is displayed onscreen, which permits you to 
access DirTrak’s menu. If a folder name parameter IS passed to DirTrak the main 
window is NOT displayed onscreen – the directory creation window is displayed only. 
After DirTrak has created the new folder, DirTrak is completely closed and control is 
passed back to Total Commander.  

Note: DirTrak was developed with Clarion version 11, which still does not support 
Unicode. Non-ASCII characters cannot be handled correctly by the language – meaning 
that a folder name that contains Unicode formatted characters will be translated to a 
different character by the language and it can’t be created via DirTrak. 

Safeguards
DirTrak will abandon the directory operation if either of these conditions exist:

1. A file or folder of the new name already exists in the selected folder
2. The new path+folder name exceeds 259 characters (because Windows max 

preferred path length for a file or folder is 260 characters without causing major 
problems)

System Requirements
 Windows 8 (or higher)
 All Windows applications “like” computer memory – a starting point for any Windows 

machine should really be 16GB of memory. If this application starts running slower, 
check your Windows Task Manager for applications that are leeching memory (and then 
start closing them)

 This application runs comfortably within 10MB of disc space
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 A decent color monitor capable of displaying 1024x768 (or higher resolution)

U.S. Government Use
U.S. government agencies, to include the Department of Defense, are NOT permitted to use this 
application without written consent from the author. A per-seat usage fee will be assessed prior 
to that written authorization being granted to the requester.

Quick Start
DirTrak is simple to implement. Install the application to a dedicated folder. All DirTrak 
configuration options are displayed in the popup DirTrak window. Configuration settings 
are automatically saved to the DirTrak.ini file when DirTrak closes.

How It Works
When DirTrak is started via a file manager application, the following actions occur: 
1. DirTrak.ini file is opened and saved settings are loaded into memory
2. The parameter passed by the file manager application is evaluated/processed to 

determine if a folder name was passed to it. If a folder name was passed, the 
path components of the passed string are loaded into variables 

3. The variables are preloaded into the onscreen entry fields and display strings
4. The Filename Case droplist is changed to reflect the DirTrak.ini saved value
5. The user (aka: you) enter the new folder name into the onscreen entry field 
6. When the MAKE NEW DIRECTORY button is pressed (or the Enter key is pressed, 

which automatically ‘clicks’ the MAKE NEW DIRECTORY button, the entered 
folder name case is converted as instructed by the Filename Case droplist value; 
the individual components are pieced back together 

7. The pieced folder name is then checked for its existence in the current path – if 
it exists, a popup error window is displayed onscreen and DirTrak terminates 
without completing the folder creation operation

8. If the pieced together folder name length exceeds 259 total characters a popup 
error window is displayed onscreen and DirTrak terminates without completing 
the folder creation operation

9. If the new folder name does not exist in the current path and the total length is 
less than 259 total characters, the folder creation operation is completed

10. DirTrak closes and full control is passed back to the file manager application
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Screen Captures

Main Window 
The DirTrak window is simple, with a standard Windows pulldown menu that can be 
executed with the mouse or keyboard:  

 
The main window’s menu options are purposely small, with the two important menu 
options being  File->About and File->Exit.  

Folder Creation Window 
If a parameter (e.g. D:\Music\) is passed to DirTrak, the main DirTrak window is 
bypassed and the main folder creation window is displayed onscreen:  
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The folder name entry field accommodates 120 characters – this limitation 
ensures that the full pathname + folder name does not exceed the Windows 
length limitation. 

The Suffix Text entry field isn’t *really* an entry field – it is linked to a special 
DirTrak database that stores predefined text that is appended to the end of the 
Folder Name. A folder name suffix is *not* mandatory – you may skip over this 
entry field altogether if that is the case. There are two methods of displaying 
the contents of the Suffix Text database when this entry field has focus:

1. Press the Alt-DownArrow keys together
2. Click the icon displayed to the right of the entry field

When accessed, the Suffix Text popup window resembles this:
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Displayed to the right of the listbox that displays the saved database entries are 
buttons to Insert, Change, and Delete entries stored within that Suffix Text 
database. The listbox automatically sorts the entries in ascending alphabetic 
sequence. 

To select a listbox entry, select the desired entry with the mouse or with the 
up/down keyboard keys and then either press the Enter key, click the button 
titled Select Highlighted Entry, or press the Alt-S keys simultaneously. 

There is no limit to the number of Suffix Text database entries that you can 
create/store in its database.

There is an alternate method of selecting a Suffix Text database entry without 
displaying the popup window – when the Suffix Text entry field has focus, the 
Up and Down arrow keys will cycle through the database entries and enter the 
value into the entry field. 

Suffix Text database entries can be defined “on-the-fly” during use, or the 
popup window can be accessed via the DirTrak main menu (File->Browse Suffix 
Text Picklist). Please note that the suffix text is appended to the folder name 
EXACTLY as it is stored within the Suffix Text database – in most instances, it is 
desirable (but not mandatory) to start off the Suffix Text with a blank space.  

Two checkboxes (whose values are true if checkmarked and false if not 
checkmarked) will capitalize the character following a semicolon and determine 
where the cursor is placed within the folder name entry field when DirTrak 
initializes. The checkbox values (checked/unchecked) are saved to the 
DirTrak.INI file when the application is closed and retrieved when DirTrak 
initializes. 

The name case droplist has four possible values and can be changed at any 
time:

Tabs 2-4 of the DirTrak window displays helpful information to (a) configure a Total 
Commander button to DirTrak and (b) how to assign the F7 key to DirTrak:
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Tabs 5-6 of the DirTrak window displays helpful information to (a) configure a 
SpeedCommander button to DirTrak and (b) how to assign the F7 key to DirTrak:
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Technical Information
This application requires less than 5MB of disc space for its files: 

 DirTrak.exe – application file
 DirTrak.Ini – configuration file (editable with Notepad or a text editor)

These files can be installed anywhere on your computer.  The currently logged on 
Windows user must have WRITE security permissions to the installation folder make 
changes to the DirTrak.ini file. DirTrak requires about 3.0MB of disc space, plus the size 
of the user manual (which can be deleted if space needs to be reclaimed on your hard 
drive).
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File Manager Integration
Listed below are step-by-step instructions on integrating DirTrak into several popular 
file manager applications:

DoubleCommander

1. Right click on an empty space within the vertical toolbar; select EDIT
2. Add a new button to the toolbar; configure its settings to mimic this:

 
The important setting is the Parameter variable being passed: %D

The above screen capture shows the F7 key being assigned to the DirTrak application.

FreeCommander
DirTrak is easily integrated into FreeCommander; here is a series of screen captures that 
shows how this is done: 

1. Open FreeCommander
2. Right click the mouse in the upper toolbar and select the popup menu item 

‘Customize favorite toolbars’:

3. Click the icon with a “+” symbol to add a new Favorite shortcut to the 
FreeCommander toolbar:
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4. Select the new Favorite and then populate the configuration options similar to 
this:

Name: This text is displayed in the toolbar
Program or Folder: Click the file selection button and navigate to where DirTrak 
is installed
Start Folder: Same as the DirTrak installation folder
Parameter: %ActivDir%
Icon File: Select the DirTrak executable and select icon #3 from the droplist (or 
your favorite icon)
Hotkey: Your choice to define a hotkey; I’ve configured the F7 key to execute 
DirTrak (which is defined as Favorite Tool 07 for my FreeCommander 
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configuration)

Click OK to save the toolbar options. Don’t forget to select ‘Tools -> Save 
Settings’ from the FreeCommander main menu to save all of the options to the 
FreeCommander settings file(s).

SpeedCommander
DirTrak can be integrated into SpeedCommander; here is a series of screen captures 
that shows how this is done: 

1. Select EXTRAS, then USER TOOLS, then CONFIGURE from the main menu:

              
2. Select NEW from the popup window; enter DirTrak in the next popup to enter a 

User Friendly description, and then populate the values for the path to the .EXE 
file, the folder to start DirTrak within (the same location as the .Exe file). For the 
Parameters entry field, enter $(ActDir); the window will resemble something like 
this:
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3. After populating the information, click APPLY then OK to save the new User Tool. 
I prefer using the F7 keyboard key to create a new folder – to assign 
SpeedCommander to use DirTrak when that key is pressed from within 
SpeedCommander:

4. Select EXTRA, then CUSTOMIZE from the main menu; this popup window will 
appear:

5. Select the KEYBOARD tab
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Enter ‘DirTrak’ or ‘Trak’ (minus the quotation marks) to pinpoint the User Tools.DirTrak 
entry

6. Enter the desired hotkey combination or function key into the ‘Shortcuts for 
selected command:’ entry field, then click the Assign button [Note: you may 
need to remove the desired shortcut first if SpeedCommander is currently using 
it for another command] the final result will resemble:



                                           Software by Daughtry | Complexity Made Simple                            Page 16

Total Commander
DirTrak is designed to be integrated into Total Commander (versus executed on its 
own). The parameter passed from Total Commander to DirTrak must be the full 
path+filename of the currently highlighted folder – Total Commander provides the 
required information via the combination of this predefined parameter: %P

Configuring Total Commander to use DirTrak is simple and takes 60 seconds to 
complete. You can configure Total Commander to use DirTrak via a button added to the 
vertical splitter bar and/or by pressing the F7 key 
 

a. Add a vertical button for DirTrak:
1. Right click the mouse on the vertical splitter bar and select ‘Change Vertical 

Button Bar’ from the popup list of items:

2. Click the ADD button and populate the button’s configuration settings similar 
to this screen capture:

3. Click OK to save the newly added button’s settings

b. Assign the F7 hotkey for DirTrak:
1. Click CONFIGURATION in the Total Commander main menu
2. Select ‘Options’ 
3. Select ‘Misc.’
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4. Click the button with a downarrow symbol:

5. From the droplist of key mappings select ‘F7’ and the applicable 
cm_UserMen<n> entry assigned to DirTrak:

6. The screen will now show the F7 key is assigned to the cm_UserMenu<n> 
assigned to DirTrak:

7. Click OK to close the window
8. Click CONFIGURATION in the Total Commander main menu
9. Click SAVE SETTINGS
10. Done

Support and Registration/Donation
1. Send us an email (scott@sdaughtry.com) that fully describes the problem(s) you’re 

experiencing and we will get back to you as soon as possible. It is prudent for you to 
fully back up this application’s folder (in full) as a precautionary pre-troubleshooting 
step.

2. This application is distributed as DONORWARE – no features have been removed or 
crippled from this application. This application’s dedicated web page located on our 

mailto:scott@sdaughtry.com
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company web site (http://www.sdaughtry.com) has a link to donate to continued 
updates of this application and/or fund the creation of other utility applications. 

http://www.sdaughtry.com
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